Tag Archives: PHP

PHP 7 and why you should be using it

New and Improved PHP

The long-awaited next version of PHP, version 7.0, was released at the end of 2015 and has been since receiving regular updates. With this new version of PHP, amazing speed and new features came along with it. Because it was released over three years ago now, PHP 7.0 itself is actually nearing End of Life status (this means it will not receive updates in any capacity) and PHP 7.3 or 7.2 are the more preferred versions of PHP to have your site use.

The life-cycle of PHP can be found here:

https://secure.php.net/supported-versions.php

The graph from the PHP link above can be translated into this easier to read/understand text:

  • 5.6 stopped receiving Security Support at the end of 2018
  • 7.0 stopped receiving Security Support at the beginning of December 2018
  • 7.1 received regular updates until the beginning of December 2018 and will continue to receive Security Support until the beginning of December 2019
  • 7.2 will receive regular updates until the beginning of December 2019 and Security Support until the beginning of December 2020
  • 7.3 will receive regular updates until the beginning of December 2020 and Security Support until the beginning of December 2021

While version 5.6 and 7.0 recently received critical security updates, your sites really should be using PHP 7.3, if not, PHP 7.2. PHP 7.3 is available on both cPanel and WordPress Only hosting platforms!

There have been some new features added, some things taken away (for good reason), and it’s wicked fast. As PHP 5.6 and 7.0 support ended recently, and 7.1 support ending at the end of the year, we would like to start getting everyone switched over to at least 7.2 or preferably 7.3.

How to Update PHP for Your Site on cPanel

There are a couple ways you can get the PHP version for your site changed. If you or your developer would like to handle this all yourself, you can change the PHP version using the MultiPHP Manager in your cPanel account. In the search box at the top of your cPanel account, search for “MultiPHP Manager” and click the resulting icon. Now, it’s all on a site-by-site basis, so you will need to change each site to a new version of PHP. You can click the checkbox to select all and mass change them or go one-by-one and then test the site to ensure it still functions as expected.

The second option would be to have us switch the versions for you. We can do this site-by-site or all at once. If you would like to schedule this change, please visit the following URL and sign up for a timeslot, adding the domain(s) you want to be switched into the “additional info” box:

https://calendly.com/bch-status/30min

We will switch the PHP version to 7.3 and make sure the site(s) load and click a few links to see that they still work. If there are any issues, we will try 7.2, 7.1, or 7.0 if needed, and failing that change, switch you back to PHP 5.6. Once we’ve finished the testing, we’ll send you an email letting you know the outcome of the change. At that point, we highly encourage you to test all facets of your site to ensure that they function as expected. After all, you know your site best!

If there are any issues, it’s likely going to be due to a plugin that either needs to be updated within your site or the developers need to push out an update. Either way, we’ll make sure you have all the needed information to move forward.

How to Update PHP For Your Site on WordPress Only

If you are using our WordPress Only product, please visit the following URL and sign up for a timeslot, adding the domain(s) you want to be switched into the “additional info” box:

https://calendly.com/bch-status/30min

We will switch the PHP version to 7.3 and make sure the site(s) load and click a few links to see that they still work. If there are any issues, we will work our way down to a version that works with your site. Once we’ve finished the testing, we’ll send you an email letting you know the outcome of the change. At that point, we highly encourage you to test all facets of your site to ensure that they function as expected. After all, you know your site best!

If there are any issues, it’s likely going to be due to a plugin that either needs to be updated within your site or the developers need to push out an update. Either way, we’ll make sure you have all the needed information to move forward.

PHP Compatibility Checker

This plugin can be used to scan your site for potential issues with PHP 7+. It does rely on wp-cron to be functioning properly or else the scan can get stuck. While this plugin is written to detect as many problems as accurately as possible, 100% reliable detection is very difficult to ensure. Please note that this is a third-party plugin (not provided by BCH) that we found to help aid you in the transition from PHP 5 to PHP 7.

https://wordpress.org/plugins/php-compatibility-checker/

There is an option to scan only active themes and plugins which would help the scan complete sooner. Though, if you have any inactive plugins that you intend to use, you should scan them as well. Any plugins you do not plan to use should be removed (bonus: this helps save on disk space!).

If any questions arise about the version change process, PHP in general, or whatever else, please don’t hesitate to open a ticket with support@blackchickenhost.com.